Manual browser: acpivga(4)
|ACPIVGA(4)||Kernel Interfaces Manual||ACPIVGA(4)|
NAMEacpivga — ACPI Display Adapter and Output Devices
SYNOPSISacpivga* at acpi?
acpiout* at acpivga?
DESCRIPTIONThe acpivga driver provides generic support for brightness control and output switching, through ACPI video extensions. The ACPI specification requires that systems containing a built-in display adapter implement these extensions in their ACPI BIOS.
The driver handles brightness hotkeys and display switch hotkeys. In addition, the following sysctl(8) read/write variables are provided (when hardware support is available):
BIOS output switching policy. This boolean variable controls the behavior of the BIOS when a display switch hotkey is pressed.
- the BIOS should automatically switch outputs, with no interaction from acpivga.
- the BIOS should only notify acpivga of the desired output state changes.
- Brightness level. This integer variable typically ranges from 0 to 100, but any integer value is accepted (the driver uses the closest brightness level supported by the device).
Please note, however, that future versions of acpivga may remove these sysctl(8) variables without prior notice.
SEE ALSOacpi(4), vga(4), sysctl(8)
Microsoft Corporation, Mobile System Displays and Windows, Version 1.2c, http://www.microsoft.com/whdc/archive/mobiledisplay.mspx, December 4, 2001.
HISTORYThe acpivga driver appeared in NetBSD 6.0.
CAVEATSThe acpivga driver only supports PCI/PCI-X/PCI-E display adapters.
Many ACPI BIOSes implement only part of the ACPI video extensions. In particular, display output switching via these extensions often does not work. For this reason, acpivga enables hw.acpi.acpivga0.bios_switch by default. If the display switch hotkey does not work with this default setting, try setting hw.acpi.acpivga0.bios_switch to 0.
|October 28, 2010||NetBSD 7.0|