Manual browser: alc(4)
|ALC(4)||Kernel Interfaces Manual||ALC(4)|
NAMEalc — Atheros AR813x/AR815x/AR816x/AR817x Ethernet device
SYNOPSISalc* at pci?
atphy* at mii?
DESCRIPTIONThe alc driver provides support for Ethernet interfaces based on the Atheros AR813x/AR815x/AR816x/AR817x Gigabit/Fast Ethernet chipsets.
The following media types are supported:
- Enable autoselection of the media type and options.
- Set 10Mbps operation.
- Set 100Mbps (Fast Ethernet) operation.
- Set 1000Mbps (Gigabit Ethernet) operation.
For more information on configuring this device, see ifconfig(8).
SEE ALSOarp(4), atphy(4), ifmedia(4), intro(4), netintro(4), pci(4), ifconfig(8)
HISTORYThe alc device driver was written by and first appeared in FreeBSD 8.0. It was ported to OpenBSD 4.7 by and then ported to NetBSD 6.0 by . ported the AR816x/AR817x support for alc from FreeBSD 11.0.
|January 18, 2015||NetBSD 7.0|