Manual browser: auvitek(4)
|AUVITEK(4)||Kernel Interfaces Manual||AUVITEK(4)|
NAMEauvitek — Auvitek AU0828 video capture device driver
SYNOPSISauvitek* at uhub?
dtv* at dtvbus?
video* at videobus?
uaudio* at auvitek?
audio* at uaudio?
DESCRIPTIONThe auvitek driver provides support for USB video capture devices based on the Auvitek AU0828 bridge. This hybrid analog/digital device requires a hi-speed USB host controller (such as ehci(4)) to function properly.
For auvitek devices with analog audio capture interfaces, the uaudio(4) device driver provides access to the audio stream. Application software can find a video(4) device's audio(4) device by comparing the VIDIOC_QUERYCAP bus_info field with the audio device's AUDIO_GETDEV config field.
The following cards are supported by the auvitek driver:
Cards with an XC5000 tuner require the firmware provided by the pkgsrc/sysutils/xc5k-firmware package to function properly.
HISTORYThe auvitek device driver appeared in NetBSD 6.0.
AUTHORSThe auvitek driver was written by <jmcneill@NetBSD.org>.
|August 30, 2011||NetBSD 7.0|