Manual browser: bwi(4)
|BWI(4)||Kernel Interfaces Manual||BWI(4)|
NAMEbwi — Broadcom BCM430x/4318 IEEE 802.11b/g wireless network driver
SYNOPSISbwi* at pci? dev ? function ?
bwi* at cardbus? function ?
DESCRIPTIONThe bwi driver provides support for Broadcom BCM430x/4318 wireless network adapters. For more information on configuring this device, see ifconfig(8).
MIB VariablesThe following per-interface variables are implemented in the hw.bwiX branch of the sysctl(3) MIB.
- Debug flags.
- Channel dwell time during scan (msec).
- Firmware version.
- Number of ticks before LED enters idle state.
- Allow LED to blink.
- Enable software TX power calibration.
HARDWAREThe following cards are among those supported by the bwi driver:
|Dell Wireless 1370||BCM4318||Mini PCI||b/g|
|Dell Wireless 1470||BCM4318||Mini PCI||b/g|
|Dell Truemobile 1400||BCM4309||Mini PCI||b/g|
|Dell Latitude D505||BCM4306||PCI||b/g|
|Apple AirPort Extreme||b/g|
FILESThe firmware for the adapter is not shipped with NetBSD and must be obtained separately. An archive with firmware files that are known to work can be found at:
The firmware files conventionally reside in /libdata/firmware/bwi and will be loaded when the interface is brought up. Note: the v3 subdirectory in the above firmware archive should exist in the firmware folder. The full list of paths checked for firmware can be found in the hw.firmware.path sysctl(3) node.
SEE ALSOarp(4), cardbus(4), ifmedia(4), pci(4), ifconfig(8), sysctl(8), wiconfig(8), wpa_supplicant(8)
HISTORYThe bwi driver first appeared in NetBSD 6.0.
AUTHORSThe bwi driver was written by for Dragonfly BSD. It was ported to NetBSD by <riastradh@NetBSD.org>.
The hardware specification was reverse engineered by the people at http://bcm-specs.sipsolutions.net. Thanks go also to johill and mb on the #bcm-specs channel.
BUGSBCM4306 and BCM4309 chips do not work properly on channel 1, 2, and 3.
|April 25, 2012||NetBSD 7.0|