Manual browser: ciss(4)
|CISS(4)||Kernel Interfaces Manual||CISS(4)|
NAMEciss — HP/Compaq Smart ARRAY 5/6 RAID controllers
SYNOPSISciss* at pci? function ?
DESCRIPTIONThe ciss driver provides support for the CISS interface implemented by fifth and later generations of the HP/Compaq Smart ARRAY family of controllers.
The CISS interface is defined in the document entitled CISS Command Interface for SCSI-3 Support Open Specification, Version 1.04, Valence Number 1, Compaq Computer Corporation, 2000/11/27.
This driver supports several Compaq and HP controllers implementing the CISS interface, including:
- Compaq Smart Array 5300 version 1
- Compaq Smart Array 5300 version 2
- Compaq Smart Array 5i version 1
- Compaq Smart Array 5i version 2
- HP Smart Array 5312
- HP Smart Array 6i
- HP Smart Array 641
- HP Smart Array 642
- HP Smart Array 6400
- HP Smart Array 6400 EM
- HP Smart Array E200
- HP Smart Array E200i
- HP Smart Array P400
- HP Smart Array P400i
- HP Smart Array P600
- HP Smart Array P800
- HP Smart Array V100
- HP Smart Array 1 through 13
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superpositions of those configurations.
Although the controllers are actual RAID controllers, the ciss driver makes them look just like SCSI controllers. All RAID configuration must be done through the controllers' BIOSes.
Hardware from previous generations of this product family may be supported by the cac(4) driver.
HISTORYThe ciss driver first appeared in NetBSD 3.1.
AUTHORSThe ciss driver was written by <firstname.lastname@example.org>, and ported to NetBSD by <email@example.com>.
|May 28, 2008||NetBSD 7.0|