Manual browser: g760a(4)
|G760A(4)||Kernel Interfaces Manual||G760A(4)|
NAMEg760a — Global Mixed-mode Technology Inc. G760a fan speed controller driver
SYNOPSISg760a0 at iic? addr 0x3e
DESCRIPTIONThe g760a driver provides support for the Global Mixed-mode Technology Inc. G760a on iicbus fan speed controller to be used with the envsys(4) API. This chip could be found in D-Link's DNS-323 NAS box.
The following sysctl(8) variable controls the fan's speed:
This value specifies the desired speed for the fan. Valid range is 2000..20000 or 0 (the fan is turned off). The default value is 0.
When setting the desired speed the RPM number will be converted to the internal representation and truncated. For example when you are setting 2000 it will be truncated to 2006, and 8000 will be changed to 8057.
SEE ALSOenvsys(4), lm(4), envstat(8)
AUTHORSThe g760a driver was written by .
|April 11, 2008||NetBSD 7.0|