Manual browser: gem(4)
|GEM(4)||Kernel Interfaces Manual||GEM(4)|
NAMEgem — ERI/GEM/GMAC Ethernet device driver
SYNOPSISgem* at pci? dev ? function ?
gem* at sbus? slot ? offset ?
Configuration of PHYs may also be necessary. See mii(4).
DESCRIPTIONThe gem driver provides support for the GMac Ethernet hardware found mostly in the last Apple PowerBooks G3s and most G4-based Apple hardware, as well as many Sun UltraSPARCs.
Cards supported by this driver include:
- Sun GEM gigabit ethernet (SX fibre variants)
- Sun ERI 10/100
- Apple GMAC
The GEM family supports hardware checksumming to assist in computing IPv4 TCP checksums. The gem driver supports this feature of the chip. See ifconfig(8) for information on how to enable this feature.
SEE ALSObmtphy(4), ifmedia(4), intro(4), mii(4), ifconfig(8)
Sun Microsystems, GEM Gigabit Ethernet ASIC Specification, http://www.sun.com/processors/manuals/ge.pdf.
Sun Microsystems, Sbus GEM Specification, http://mediacast.sun.com/users/Barton808/media/gem_sbus-1.pdf.
HISTORYThe gem device driver appeared in NetBSD 1.6. Support for PCI SX fibre cards was added in NetBSD 5.0. Support for SBus SX fibre cards was added in NetBSD 5.0.
AUTHORSThe gem driver was written by <eeh@NetBSD.org>. SX fibre support was added by <jdc@NetBSD.org>. The man page was written by <wiz@NetBSD.org>.
BUGSThe hardware checksumming support does not support IPv4 UDP, although this was allowed prior to NetBSD 5.0. Also, the hardware IPv4 TCP receive checksumming support has bugs, so this is disabled.
On the SX fibre variants of the hardware, the link will stay down if there is a duplex mismatch. Also, packet transmission may fail when in half-duplex mode.
|September 15, 2008||NetBSD 7.0|