Manual browser: genfb(4)
|GENFB(4)||Kernel Interfaces Manual||GENFB(4)|
NAMEgenfb — generic framebuffer console driver
SYNOPSISgenfb* at pci?
genfb* at sbus?
wsdisplay* at genfb?
DESCRIPTIONThe genfb driver provides support for generic framebuffers that have no native driver. All it needs are some parameters to describe the framebuffer and an address.
PCIWhen attaching to a pci(4) bus the driver is configured via device properties:
- Width in pixels.
- Height in pixels.
- Line size in bytes.
- Bits per pixel.
- If true, genfb will try to become the system console.
- Bus address of the framebuffer.
SBusWhen attaching to sbus(4) all those parameters are retrieved from the firmware.
BUGSThere is no way to change the color map even when the firmware supports it. The pci(4) bus frontend has only been tested on macppc, i386, and amd64 and requires machine dependent code to pass the properties mentioned above. So far only macppc, i386, and amd64 provides them.
|August 23, 2009||NetBSD 7.0|