Manual browser: gtp(4)
|GTP(4)||Kernel Interfaces Manual||GTP(4)|
NAMEgtp — Gemtek PCI FM radio device
SYNOPSISgtp* at pci? flags 0x00
radio* at gtp?
DESCRIPTIONThe gtp driver provides support for the Gemtek PCI and Guillemot MaxiRadio FM2000 FM radio tuners.
The Gemtek PCI cards are stereo FM tuners that can tune in the range 87.5 - 108.0 MHz, report signal status and stereo/mono on the current frequency, force audio output to mono, perform hardware signal search, and have an internal AFC.
The card is based on the TEA5757 chip; see radio(4) for details.
The flags control the driver behavior. For example, with flags 0x01 the driver will assume that a TEA5759 chip is used.
HISTORYThe gtp device driver appeared in OpenBSD 3.2 and subsequently in NetBSD 1.6 wherein it replaced the mr(4) driver.
AUTHORSThe gtp driver and the man page was written by <email@example.com>.
BUGSIt is impossible to determine which frequency the card is tuned to. Thus, the driver will report an internally stored value even if it is not correct (changed by some program that uses direct port access).
|March 26, 2011||NetBSD 7.0|