Manual browser: ieee1394if(4)
|IEEE1394IF(4)||Kernel Interfaces Manual||IEEE1394IF(4)|
NAMEieee1394if — IEEE1394 High-performance Serial Bus
SYNOPSISieee1394if* at fwohci?
DESCRIPTIONNetBSD provides machine-independent bus support and raw drivers for IEEE1394 interfaces.
The ieee1394if driver consists of two layers: the controller and the bus layer. The controller attaches to a physical bus (like pci(4)). The ieee1394if bus attaches to the controller. Additional drivers can be attached to the bus.
Up to 63 devices, including the host itself, can be attached to a IEEE1394 bus. The root node is dynamically assigned with a PHY device function. Also, the other IEEE1394 bus specific parameters, e.g., node ID, cycle master, isochronous resource manager and bus manager, are dynamically assigned, after bus reset is initiated. On the ieee1394if bus, every device is identified by an EUI 64 address.
HISTORYThe ieee1394if driver first appeared in FreeBSD 5.0, as firewire. It was added to NetBSD 4.0 under its present name.
AUTHORSThe ieee1394if driver was written by and for the FreeBSD project. It was added to NetBSD 4.0 by .
BUGSSee fwohci(4) for security notes.
|June 18, 2005||NetBSD 7.0|