Manual browser: isdn(4)
|ISDN(4)||Kernel Interfaces Manual||ISDN(4)|
NAMEisdn — ISDN kernel to userland master device
DESCRIPTIONThe isdn device driver is used by the isdnd(8) daemon to exchange messages with the ISDN kernel part for the purpose of call establishment, control and disconnection and to access various control and status information.
The messages and message parameters are documented in the include file /usr/include/netisdn/i4b_ioctl.h.
The available ioctl's are:
- Request a unique Call Description IDentifier (cdid) which identifies uniquely a single interaction of the local D channel with the exchange.
- Actively request a call setup to a remote ISDN subscriber.
- Respond to an incoming call, either accept, reject or ignore it.
- Actively terminate a connection.
- Request information about an installed ISDN controller card.
- Give information about call setup to driver who requested dialing out.
- Update the kernels timeout value(s) in case of dynamically calculated shorthold mode timing changes.
- Inform the kernel userland drivers about interface soft up/down status changes.
- Download firmware to active card(s).
- Return diagnostic information from active cards.
Status and event messages available from the kernel are:
- An incoming call from a remote ISDN user is indicated.
- After an incoming call has been accepted locally or an outgoing call has been accepted by a remote, the exchange signaled an active connection and the corresponding B-channel is switched through.
- A call was terminated.
- A userland interface driver requests the daemon to dial out (typically a network interface when a packet arrives in its send queue).
- A call was terminated by the isdn4bsd kernel driver because a B-channel idle timeout occurred.
- Accounting information from a network driver.
- Charging information from the kernel.
AUTHORSThe isdn device driver and this man page were written by <email@example.com>.
|February 3, 1998||NetBSD 7.0|