Manual browser: isp(4)
|ISP(4)||Kernel Interfaces Manual||ISP(4)|
NAMEisp — Qlogic based SCSI and FibreChannel SCSI Host Adapters
SYNOPSISisp* at pci? dev? function? (PCI)
isp* at sbus? slot ? offset ? (SBus)
scsibus* at isp?
DESCRIPTIONThis driver provides access to SCSI or FibreChannel devices.
SCSI features include support for Ultra SCSI and wide mode transactions for SCSI, and LVD (for the ISP1080 and ISP1280),
Fibre Channel support uses FCP SCSI profile for FibreChannel. and uses Class 3 connections only. Support is available for Public and Private loops. Command tagging is supported for all (in fact, FibreChannel requires tagging).
CONFIGURATIONAn optional flags 0x80 appended to the above isp* declarations will disable the download of driver firmware, which means you use whatever firmware is running on the card. If no firmware is running on the card, the driver cannot operate the card.
An optional flags 0x40 appended to the above isp* declarations (can be OR'd in with the other config flags option) will keep the driver from looking at device or bus NVRAM settings (this is in case NVRAM is just wrong and you have the card in a platform where it is inconvenient to change NVRAM settings on the card).
HARDWARESupported cards include:
- SBus Fast Wide, Ultra Fast Wide cards, Single Ended or Differential cards.
- PTI SBS440
- Performance Technology ISP1000 variants.
- Qlogic 1020 Fast Wide and Differential Fast Wide PCI cards.
- Qlogic 1040 Ultra Wide and Differential Ultra Wide PCI cards.
- PTI SBS450
- Performance Technology ISP1040 variants.
- Qlogic 1240
- Qlogic 1240 Dual Bus Ultra Wide and Differential Ultra Wide PCI cards.
- Qlogic 1080
- Qlogic 1280 LVD Ultra2 Wide PCI cards.
- Qlogic 1280
- Qlogic 1280 Dual Bus LVD Ultra2 Wide PCI cards.
- Qlogic 2100
- Qlogic 2100 and 2100A Copper and Optical Fibre Channel Arbitrated Loop
- Qlogic 2102
- Qlogic Dual Loop 2100A Optical Fibre Channel Arbitrated Loop PCI cards.
- Qlogic 2200
- Qlogic 2200 Copper and Optical Fibre Channel Arbitrated Loop PCI cards.
- Qlogic 2202
- Qlogic 2200 Dual Bus Optical Fibre Channel Arbitrated Loop PCI cards.
- Qlogic 2204
- Qlogic 2200 Quad Bus Optical Fibre Channel Arbitrated Loop PCI cards.
- Qlogic 2300
- Qlogic 2300 2-Gigabit Optical Fibre Channel PCI cards.
- Qlogic 2312
- Qlogic 2300 2-Gigabit Dual Channel Optical Fibre Channel PCI cards.
- PTI SBS470
- Performance Technology ISP2100 variants.
- Antares P-0033
- Antares Microsystems ISP2100 variants.
- Qlogic 2400
- Qlogic 2400 4-Gigabit Optical Fibre Channel PCI cards.
- Qlogic 2500
- Qlogic 2500 8-Gigabit Optical Fibre Channel PCI cards.
AUTHORSThe isp driver was written by Matthew Jacob for NASA/Ames Research Center.
BUGSThe driver currently ignores some NVRAM settings.
The driver currently doesn't do error recovery for timed out commands very gracefully.
Sometimes, when booting, the driver gets stuck waiting for the Fibre Channel firmware to tell it that the loop port database is ready. In this case you'll see an announcement that the loop state has a value of 0x1. To unwedge the system, unplug and replug the fibre channel connection, or otherwise cause a LIP (Loop Initialization Primitive sequence) - this will kick the firmware into getting unstuck.
|June 24, 2009||NetBSD 7.0|