Manual browser: isv(4)
|ISV(4)||Kernel Interfaces Manual||ISV(4)|
NAMEisv — IDEC Supervision/16 image capture board
SYNOPSISisv0 at isa? port 0x2f0
isv0 at isa? port 0x2e0
isv0 at isa? port 0x3f0
isv0 at isa? port 0x3e0
DESCRIPTIONisv is a driver for the IDEC Supervision/16, an image capture board that plugs into a 16-bit ISA bus. The IDEC Supervision/16 digitizes an NTSC television signal, storing a 512 x 480-pixel, 8-bit grayscale image in its 256kB dynamic RAM array every 1/30th of a second. The host reads frames from the DRAM using 122881 16-bit I/O reads. Reading frames from the Supervision/16 is quite slow: after the host reads a 16-bit word from the DRAM, the Supervision/16 state machine takes approximately 0.5 microseconds to get ready for the next read. Theoretically, a frame rate of approximately 10 frames per second is possible. isv achieves a frame rate of approximately 6 frames per second.
SEE ALSOProgramming the Supervision/16 Image Capture Board, IDEC, circa 1991.
HISTORYThe isv device first appeared in NetBSD 5.0.
AUTHORSThe isv driver was written by <dyoung@NetBSD.org>.
BUGSSynchronizing with the hardware and reading frames from it is very CPU-intensive.
isv will not detect the capture board if it is not attached to an active video source. To force NetBSD to detect the capture board at any time, re-scan the ISA bus using, e.g., drvctl -r isa0.
|April 1, 2008||NetBSD 7.0|