Manual browser: mcd(4)
|MCD(4)||Kernel Interfaces Manual||MCD(4)|
NAMEmcd — Mitsumi CD-ROM driver
SYNOPSISmcd0 at isa? port 0x300 irq 10
DESCRIPTIONThe mcd driver provides support for Mitsumi CD-ROM controller and drive on the isa(4) bus.
- block mode Mitsumi CD-ROM devices
- raw mode Mitsumi CD-ROM devices
BUGSThe mcd hardware is difficult to probe accurately. Historically, the mcd probe would accept any return values as indicating that an mcd drive was present. Other devices, particularly ne(4) or we(4), would then be incorrectly claimed by the mcd driver. The driver now only accepts result codes known to indicate Mitsumi-compatible CD controllers, but may reject some mcd hardware which returns other result codes.
options MCD_PROMISC enables the original promiscuous probe behaviour. Use with extreme caution.
|November 29, 1994||NetBSD 7.0|