Kernel Interfaces Manual
NAME mpl115a — Freescale MPL115A2 absolute pressure sensor driver
SYNOPSIS mpl115a* at iic? addr 0x60
driver provides support for the MPL115A2 pressure sensor. It allows reporting absolute pressure through the envsys(4)
HISTORY The mpl115a device first appeared in NetBSD 7.0.
AUTHORS The mpl115a driver was written by Radoslaw Kujawa <email@example.com>. The fixed-point pressure calculation algorithm was suggested by Matt Thomas.
The MPL115A2 chip has an accuracy of +/- 1 kPa, which makes it not very useful for weather-related applications.
The envsys(4) API does not support pressure reporting yet, so the result is reported just as integer number.