Manual browser: osiop(4)
|OSIOP(4)||Kernel Interfaces Manual||OSIOP(4)|
NAMEosiop — Symbios/NCR 53C710 SCSI driver
arcosiop* at jazzio? flags 0x00000
ews4800mipsosiop* at sbdio? flags 0x00000
hppaosiop0 at gsc? flags 0x00000
mvme68kosiop0 at pcctwo? ipl 2
scsibus* at osiop?
DESCRIPTIONThe osiop driver provides support for the Symbios/NCR 53C710 SCSI controller chip.
For the Symbios/NCR 53C700 SCSI host adapters, use the oosiop(4) driver.
CONFIGURATIONThe osiop driver supports the following flags for use in config(1) files:
- bits 0-7:
- disable disconnect/reselect for the corresponding SCSI target
- bits 8-15:
- disable synchronous negotiation for SCSI target
- bits 16:
- disable DMA interrupts
“Target” is synonymous with SCSI ID number.
Note that SCSI tape drives should be allowed to perform disconnect/reselect or performance will suffer.
SEE ALSOcd(4), ch(4), esiop(4), intro(4), oosiop(4), scsi(4), sd(4), siop(4), ss(4), st(4), uk(4), scsipi(9)
HISTORYosiop driver first appeared in NetBSD 1.6.
The original NCR 53C710 driver appeared in NetBSD 1.0 amiga port, and Izumi Tsutsui <tsutsui@NetBSD.org> modified the driver and made it machine-independent.
|May 12, 2001||NetBSD 7.0|