Manual browser: pad(4)
|PAD(4)||Kernel Interfaces Manual||PAD(4)|
NAMEpad — Pseudo audio device driver
audio* at audiobus?
DESCRIPTIONpad is a pseudo-device driver which provides support for feeding back PCM data from a consumer of the audio(4) API to userland.
FILESThe pad pseudo-device driver receives data from /dev/soundN and feeds the raw PCM output to /dev/padN.
EXAMPLESThe following example streams an MP3 to an Apple AirTunes compatible device:
$ rtunes - < /dev/pad0 & $ mpg123 -a /dev/sound1 mozart.mp3
HISTORYThe pad driver appeared in NetBSD 5.0.
|November 11, 2007||NetBSD 7.0|