Manual browser: pcic(4)
|PCIC(4)||Kernel Interfaces Manual||PCIC(4)|
NAMEpcic — Intel and Cirrus Logic PCMCIA controller driver
SYNOPSISpcic0 at isa? port 0x3e0 iomem 0xd0000 iosiz 0x4000 flags N
pcic1 at isa? port 0x3e2 iomem 0xd4000 iosiz 0x4000 flags N
pcic* at isapnp?
pcic* at pci? dev? function ?
pcmcia* at pcic? controller ? socket ?
DESCRIPTIONNetBSD provides support for the Intel 82365SL, Cirrus Logic PD6710 and PD672x PCMCIA controllers.
For the isa(4) attachment a flags value of 1 can be used to force the use of polling instead of interrupts for card events.
The default configuration of the pcic gives each controller 16 kilobytes of memory, to be shared between slots. Some PC Card devices require somewhat more memory than this; it may therefore be necessary to adjust the iomem and iosiz parameters of the pcic devices in the kernel config file to accommodate these cards.
SEE ALSOisa(4), isapnp(4), pci(4), pcmcia(4), tcic(4)
HISTORYThe pcic driver appeared in NetBSD 1.3.
|May 21, 1999||NetBSD 7.0|