Manual browser: piixpcib(4)
|PIIXPCIB(4)||Kernel Interfaces Manual||PIIXPCIB(4)|
NAMEpiixpcib — Intel PIIX4 PCI-ISA bridge with SpeedStep
SYNOPSISpiixpcib* at pci? dev ? function ?
isa* at piixpcib?
DESCRIPTIONThe piixpcib driver provides support for the Intel PIIX and compatible PCI-ISA Bridges with Intel's first generation SpeedStep.
Frequency scaling is supported on Pentium III with two voltage modes, used by SpeedStep as power states low and high. The driver will switch into low power state by reducing voltage and frequency of the CPU. The factor depends on the processor itself, but will always reduce power consumption about 1/2.
The user can manually control the CPU frequency with the sysctl(8) program using the following node:
- machdep.speedstep_state = [0/1]
HISTORYThe piixpcib driver first appeared in FreeBSD 5.5 and then in NetBSD 4.0.
AUTHORSThe current piixpcib driver was written by . It was ported to NetBSD by <jmcneill@NetBSD.org>.
|March 1, 2011||NetBSD 7.0|