Manual browser: ppp(4)
|PPP(4)||Kernel Interfaces Manual||PPP(4)|
NAMEppp — point to point protocol network interface
DESCRIPTIONThe ppp interface allows serial lines to be used as network interfaces using the Point-to-Point Protocol (PPP). The ppp interface can use various types of compression and has many features over the SLIP protocol used by the sl(4) interface.
Supported options are:
- options PPP_BSDCOMP
- Enable support for BSD-compress (`bsdcomp') compression in ppp.
- options PPP_DEFLATE
- Enable support for deflate compression in ppp.
- options PPP_FILTER
- This option turns on pcap(3) based filtering for ppp connections. This option is used by pppd(8) which needs to be compiled with PPP_FILTER defined (the current default).
- ppp%d: af%d not supported.
- The interface was handed a message with addresses formatted in an unsuitable address family; the packet was dropped.
SEE ALSOinet(4), intro(4), sl(4), pppd(8), pppstats(8)
The Point-to-Point Protocol (PPP), RFC 1661, July 1994.
HISTORYThe ppp device appeared in NetBSD 1.0.
|January 10, 2005||NetBSD 7.0|