Manual browser: rumpfs(4)
|RUMPFS(4)||Kernel Interfaces Manual||RUMPFS(4)|
NAMErumpfs — rump kernel root file system
LIBRARYrump kernel (librumpvfs, -lrumpvfs)
DESCRIPTIONrumpfs is a simple in-memory file system for rump kernels. It is automatically mounted as the root file system of a rump kernel at boot time, provided that the VFS faction is configured into the rump kernel instance.
The three main features of rumpfs are:
- providing a hook for accessing host files via the rump_etfs(3) interfaces.
- supporting enough of file and directory interfaces to facilitate simple operations such as hosting config files or creating mount points.
- being small and lightweight so as to keep a barebones rump kernel lightweight.
rumpfs is not intended for hosting large files or big directory hierarchies. If faced with such a use case, mounting a tmpfs file system inside the rump kernel is recommended.
HISTORYrumpfs first appeared in NetBSD 6.0.
|March 3, 2014||NetBSD 7.0|