Manual browser: scc(4)
|SCC(4)||Kernel Interfaces Manual||SCC(4)|
NAMEscc — Zilog 8530 Serial Communications Controller interface
SYNOPSISscc* at ioasic? offset ?
DESCRIPTIONThe scc driver provides support for the Zilog 8530 Serial Communications Controller (SCC) via the IOASIC found on DECstation 5000 models in the /100, /20, and /240 series (supported by NetBSD/pmax).
Each SCC device has two serial ports. The DECstation 5000 model 20 provides one SCC device. Other models provide two, but one port of each device is dedicated to mouse and keyboard input, respectively.
Input and output for each line may set to one of following baud rates: 50, 75, 110, 134.5, 150, 300, 600, 1200, 1800, 2400, 4800, 9600, 19200, 38400, or 57600.
Speeds up to 230400 are supported by the chip and the motherboard, but speeds higher than 57600 do not work reliably without an external clock signal.
The mapping from units to serial-hardware outlets is idiosyncratic. The even ports are wired serial connectors and the odd-numbered ports are reserved for mouse and keyboard.
On machines with one port like Personal DECstations, the single device is ttya.
On the 5000/1xx and 5000/2xx, the first serial port (default serial console) is ttyc and the second port is ttya.
SEE ALSOintro(4), ioasic(4), ttys(5), MAKEDEV(8)
HISTORYThe scc driver first appeared in 4.4BSD.
The scc driver was also used for the IOASIC SCC found in DEC Alpha model 3000 TurboCHANNEL based systems; NetBSD/alpha has since been converted to use the machine-independent zstty(4).
BUGSThe IOASIC provides internal DMA channels that can be programmed to transfer up to 4096 bytes of data into, or out, of an SCC without further software intervention. This feature of the IOASIC is not yet supported.
The mapping from device-special files (major and minor number) to chip and port is arguably backwards. ULTRIX tries to hide the hardware mapping, but NetBSD does not. Users wanting to use ULTRIX compatible tty names /dev/tty0 and /dev/tty1 for the scc comm-port lines should make links or device-special files which match their hardware setup.
|April 24, 2003||NetBSD 7.0|