Manual browser: sdtemp(4)
|SDTEMP(4)||Kernel Interfaces Manual||SDTEMP(4)|
NAMEsdtemp — JEDEC JC-42.4 compatible memory module temperature sensors
SYNOPSISsdtemp* at iic? addr 0x18
sdtemp* at iic? addr 0x19
sdtemp* at iic? addr 0x1a
sdtemp* at iic? addr 0x1b
sdtemp* at iic? addr 0x1c
sdtemp* at iic? addr 0x1d
sdtemp* at iic? addr 0x1e
sdtemp* at iic? addr 0x1f
DESCRIPTIONThe sdtemp driver provides support for the Microchip Technology MCP9805/98242 and other chips that conform to JEDEC Standard 21-C section 4.7. Memory module temperature sensors are optional on DDR2 and DDR3 SDRAM DIMMs. Sensors provided by this driver, including the on-chip thresholds for the Alarm Window and Critical level, are accessed through the envsys(4) API.
The sdtemp supports temperature ranges from -256 to +255 degrees C.
Chips supported by the sdtemp driver include:
- Catalyst CAT34TS02 and CAT6095
- Analog Devices ADT7408
- Integrated Deviced Technology TSE2002B3 and TSE3000B3
- Maxim MAX6604
- Microchip Technology MCP9805, MCP9843, MCP98242, and MCP98243
- NXP Semiconductors SE97 and SE98
- STmicroelectronics STTS424 and STTS424E
SEE ALSOenvsys(4), envstat(8)
HISTORYThe sdtemp device appeared in NetBSD 6.0.
BUGSInterrupt support is unimplemented.
|January 8, 2011||NetBSD 7.0|