Manual browser: sony(4)
|SONY(4)||Kernel Interfaces Manual||SONY(4)|
NAMEsony — Sony Miscellaneous Controller
SYNOPSISsony* at acpi?
DESCRIPTIONSome Sony notebook computers have a controller that handles various built-in devices. The sony driver provides support for accessing/modifying the settings of some of these devices via the sysctl(8) interface.
The following sysctl(8) variables are available:
- hw.sony0.brt [R/W]
- Controls current LCD brightness. Range [0-8].
- hw.sony0.pbr [R/W]
- Controls power on LCD brightness. Range [0-8].
- hw.sony0.cdp [R/W]
- Controls CD power.
- hw.sony0.pid [R/O]
- hw.sony0.ctr [R/W]
- hw.sony0.pcr [R/W]
- hw.sony0.cmi [R/W]
- hw.sony0.ams [R/W]
- Audio control (mute when 0)
- hw.sony0.hke [R/O]
Indicates a Host Key Event. Bits are set when an event occurs and cleared when this value is read. The following table describes the bit set for each button pressed:
- S1 button
- S2 button
- Fn + F10 (magnify)
- Mute button
- Fn + F12 (suspend to disk)
- Fn + F7 (LCD/external monitor)
- Fn + F6 (brighter backlight)
- Fn + F5 (darker backlight)
- Fn + F4 (volume up)
- Fn + F3 (volume down)
HISTORYThe sony driver appeared in NetBSD 4.0.
AUTHORSSami Kantoluoto for the original driver and manual information. Christos Zoulas for cleaning up the driver and this manual page.
- The sony driver just parses integer values from the acpi(4) tree. It could be more intelligent and parse other controls.
- The sysctl(8) interface is not great. The names of the sysctl(8) tree are not self-explanatory.
- No validity checks are performed on the user input. Playing with random values and/or unknown controls can harm your machine.
- The name of the driver is too generic.
|December 23, 2007||NetBSD 7.0|