Manual browser: spdmem(4)
|SPDMEM(4)||Kernel Interfaces Manual||SPDMEM(4)|
NAMEspdmem — Generic Memory Module Serial Presence Detect
SYNOPSISspdmem* at iic? addr 0x50
spdmem* at iic? addr 0x51
spdmem* at iic? addr 0x52
spdmem* at iic? addr 0x53
DESCRIPTIONThe spdmem driver provides support for generic memory module Serial Presence Detect. During kernel boot it displays module type, and where possible, the size and rated speed of the memory module. Additional information such as bank configuration and width is printed if the kernel is booted in verbose mode.
The Serial Presence Detect data for each memory module is also made accessible to user mode via sysctl(8). An entry for each spdmem device is created under the hw top-level MIB.
HISTORYThe spdmem driver first appeared in NetBSD 5.0.
AUTHORSThe spdmem driver was written by <email@example.com> with additional work by <firstname.lastname@example.org>.
|August 10, 2007||NetBSD 7.0|