Manual browser: ulpt(4)
|ULPT(4)||Kernel Interfaces Manual||ULPT(4)|
NAMEulpt — USB printer support
SYNOPSISulpt* at uhub?
DESCRIPTIONThe ulpt driver provides support for Universal Serial Bus (USB) printers that follow either the USB printer uni-directional or bi-directional protocol.
Additional bits OR-ed in the minor device number with the unit number select various features of the driver:
|0x40||Do not initialize (reset) the device on the port.|
Some printers cannot handle the reset on open; in case of problems try the ulpn device.
- USB printer with reset on open
- USB printer without reset on open
SEE ALSOlpt(4), usb(4)
USB Device Class Definition for Printing Devices, USB Implementors Forum, http://www.usb.org/developers/devclass_docs/usbprint11.pdf, January 2000.
HISTORYThe ulpt driver appeared in NetBSD 1.4.
|May 16, 2009||NetBSD 7.0|