Manual browser: umodem(4)
|UMODEM(4)||Kernel Interfaces Manual||UMODEM(4)|
NAMEumodem — USB modem support
SYNOPSISumodem* at uhub?
ucom* at umodem?
DESCRIPTIONThe umodem driver provides support for USB modems in the Communication Device Class using the Abstract Control Model. These modems are basically standard serial line modems, but they are accessed via USB instead. They support a regular AT command set. The commands can either be multiplexed with the data stream or handled through separate pipes. In the latter case the AT commands have to be given on a device separate from the data device.
The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
HISTORYThe umodem driver appeared in NetBSD 1.5.
BUGSOnly modems with multiplexed commands and data are supported at the moment.
|August 16, 1999||NetBSD 7.0|