Manual browser: virt(4)
|VIRT(4)||Kernel Interfaces Manual||VIRT(4)|
NAMEvirt — rump kernel virtual network interface
DESCRIPTIONThe virt interface acts as a link between a rump kernel and a host tap(4) interface. Interface number <n> always corresponds with the host tap interface tap<n>. All data sent by virt is written into /dev/tap<n> and all data read from /dev/tap<n> is passed as Ethernet input to the rump kernel.
A virt interface can be created and destroyed in the normal fashion with ifconfig(8).
The host's tap(4) interface can be further bridged with hardware interfaces to provide full Internet access to a rump kernel.
SEE ALSOrump(3), bridge(4), tap(4), brconfig(8), ifconfig(8)
|July 3, 2013||NetBSD 7.0|