Manual browser: vnd(4)
|VND(4)||Kernel Interfaces Manual||VND(4)|
NAMEvnd — vnode disk driver
DESCRIPTIONThe vnd driver provides a disk-like interface to a file. This is useful for a variety of applications, including swap files and building miniroot or floppy disk images.
This document assumes that you're familiar with how to generate kernels and how to properly configure disks and pseudo-devices in a kernel configuration file.
In order to compile in support for the vnd, you must add a line similar to the following to your kernel configuration file:
pseudo-device vnd # vnode disk driver
To also compile in support for reading compressed disk images, add the following option to your kernel config file:
options VND_COMPRESSION # compressed vnd(4)
Compressed disk images are expected in the cloop2 format. They can be created from “normal” disk images by the vndcompress(1) program.
There is a run-time utility that is used for configuring both compressed and uncompressed vnds; see vnconfig(8) for more information.
- vnd device special files.
SEE ALSOconfig(1), vndcompress(1), fsck(8), MAKEDEV(8), mount(8), newfs(8), vnconfig(8)
HISTORYThe vnode disk driver was originally written at the University of Utah. The compression handling is based on code by <email@example.com>.
BUGSThe vnd driver does not work if the file does not reside in a local filesystem.
The vnd driver does not work if the file is sparse.
|December 18, 2009||NetBSD 7.0|