Manual browser: wdc(4)
|WDC(4)||Kernel Interfaces Manual||WDC(4)|
NAMEwdc — WD100x compatible hard disk controllers driver
ISA and ISA plug'n'play controllerswdc0 at isa? port 0x1f0 irq 14 flags 0x00
wdc1 at isa? port 0x170 irq 15 flags 0x00
wdc* at isapnp?
Open Firmware ISAwdc* at ofisa?
PCMCIA controllerswdc* at pcmcia? function ?
arm32wdc0 at pioc? offset 0x01f0 irq 9
atariwdc0 at mainbus0
amigawdc0 at mainbus0
DESCRIPTIONThe wdc driver provides the interface with the hardware for the ata(4) driver. This driver supports IDE and EIDE controllers, as well as MFM, RLL and ESDI on the ISA bus. PCI IDE controllers in legacy mode are also supported, but the pciide(4) driver may provide more functionality.
On the ISA front-end, the following flags are supported:
- Enables 32-bit I/O negotiation in the driver. This is known to cause problems with some motherboards.
- Don't probe for the second drive.
- Set WDC_CAPABILITY_ATA_NOSTREAM flag.
- Set WDC_CAPABILITY_ATAPI_NOSTREAM flag.
SEE ALSOata(4), atapi(4), intro(4), isa(4), isapnp(4), mainbus(4), ofisa(4), pciide(4), pcmcia(4), scsi(4), wd(4)
|October 8, 2003||NetBSD 7.0|