Manual browser: xennet(4)
|XENNET(4)||Kernel Interfaces Manual (Xen)||XENNET(4)|
NAMExennet — Xen frontend paravirtualized network interface
SYNOPSISxennet* at xenbus?
DESCRIPTIONThe xennet interface forms the frontend part of the paravirtualized drivers used by Xen guest domains to have network connectivity.
When the host domain is NetBSD, the endpoint of the xennet interface is a xvif(4) interface. In the XenStore, xvif and xennet are identified by “vif” (virtual interface) entries.
Conceptually, frontends and backends drivers are similar to two Ethernet cards connected via a crossover cable.
- xennet%d: can't read mac address, err %d
- The MAC address for this interface could not be read from XenStore.
- xennet%d: %s is not a valid mac address
- The MAC address specified in the configuration file of the newly created guest domain is invalid.
- xennet%d: using event channel %d
- The Xen event channel (virtual interrupt) ID associated to this xennet.
- xennet%d: using RX copy mode
- The xennet and its associated endpoint use copy mode for communication: packets are copied from one domain's memory to another.
- xennet%d: using RX flip mode
- The xennet and its associated endpoint use flip mode for communication: packets are passed by remapping memory pages between domains.
SEE ALSOifmedia(4), xenbus(4), xvif(4), ifconfig(8)
HISTORYThe xennet driver first appeared in NetBSD 3.0.
AUTHORSThe xennet driver was written by <bouyer@NetBSD.org> and <email@example.com>.
|January 8, 2011||NetBSD 7.0|