Manual browser: xpci(4)
|XPCI(4)||Kernel Interfaces Manual (Xen)||XPCI(4)|
NAMExpci — Xen frontend paravirtualized PCI pass-through driver
SYNOPSISxpci* at xenbus?
pci* at xpci?
DESCRIPTIONThe xpci driver is the frontend part of the PCI pass-through functionality that can be used by Xen guest domains to communicate with PCI devices.
From a guest point of view, xpci is similar to a pci(4) bus, except that the guest talks with the PCI backend driver instead of the real physical device directly.
When the host domain is NetBSD, the xpci driver is backed by a pciback(4) driver within the dom0.
HISTORYThe xpci driver first appeared in NetBSD 5.1.
AUTHORSThe xpci driver was written by <bouyer@NetBSD.org>.
SECURITY CONSIDERATIONSAs PCI passthrough offers the possibility for guest domains to send arbitrary PCI commands to a physical device, this has direct impact on the overall stability and security of the system. For example, in case of erroneous or malicious commands, the device could overwrite physical memory portions, via DMA.
|January 8, 2011||NetBSD 7.0|