Manual browser: zl10353(4)
|DTVIIC(4)||Kernel Interfaces Manual||DTVIIC(4)|
NAMEdtviic, au8522, cx24227, lg3303, mt2131, nxt2k, zl10353, tvpll, xc3028, xc5k — Inter IC (I2C) modules for DTV
DESCRIPTIONThe dtviic modules provide support for dtv(4) devices. The dtviic module group includes tuners, demodulators, and analog video decoders.
The usual hardware structure consists of a host controller (connected for instance via usb(4) or pci(4)) that provides the data moving facilities (for the analog or digital video streams) and an iic(4) bus over which the other chips can be configured.
For example, a typical dtv(4) setup would look like this:
- Initialize transport stream (TS) port on the host controller.
- Configure the demodulator that “demodulates” the information from an intermediate frequency (IF) that is provided to it by the associated tuner. This step typically includes setting the desired quadrature amplitude modulation (QAM) and bandwidth, among other things.
- Configure the tuner. Typically this step includes at least setting the frequency.
- Start TS transfer (using DMA transfers or USB high speed transfers).
The supported demodulators include:
- Auvitek AU8522 ATSC/QAM64/QAM256 demodulator
- Conexant CX24227 ATSC/QAM64/QAM256 demodulator
- LG LGDT3303 ATSC/QAM64/QAM256 demodulator
- MicroTune MT2131 ATSC demodulator
- NxtWave Communications NXT2004 ATSC demodulator
- Zarlink ZL10353 (Intel CE623x) COFDM/DVB-T demodulator
The supported tuners are:
- Generic PLL-based tuners
- XCeive XC3028 analog and digital tuner
- Xceive XC5000 analog and digital tuner
- dvb-fe-nxt2004.fw needed by nxt2k
- xc3028-v27.fw or xc3028L-v36.fw (provided by pkgsrc/sysutils/xc3028l-firmware) needed by xc3028
- dvb-fe-xc5000-1.6.114.fw needed by xc5k, provided by the pkgsrc/sysutils/xc5k-firmware
HISTORYThe dtviic modules first appeared in NetBSD 6.0.
AUTHORSAuthors include <jmcneill@NetBSD.org>, <jakllsch@NetBSD.org>, and <firstname.lastname@example.org>.
|August 30, 2011||NetBSD 7.0|