Manual browser: gpio.conf(5)
|GPIO.CONF(5)||File Formats Manual||GPIO.CONF(5)|
NAMEgpio.conf — GPIO config file
DESCRIPTIONThe gpio.conf file is read by the gpio rc.d script during system start-up and shutdown, and is intended for configuring GPIO pins.
FILE FORMATLines starting with a hash (‘#’) and empty lines are ignored. All other lines are passed to gpioctl(8).
- The gpio.conf configuration file resides in /etc.
- rc.d(8) script that parses gpio.conf.
EXAMPLESIn this example, if the /etc/gpio.conf config file is present pin 1 of /dev/gpio0 is set as output and named "error_led".
# Program pin 1 of /dev/gpio0 as output and name it "error_led" gpio0 1 set out error_led
|August 1, 2009||NetBSD 7.0|