Manual browser: netgroup(5)
|NETGROUP(5)||File Formats Manual||NETGROUP(5)|
NAMEnetgroup — defines network groups
DESCRIPTIONThe netgroup file specifies “netgroups”, which are sets of (host, user, domain) tuples that are to be given similar network access.
Each line in the file consists of a netgroup name followed by a list of the members of the netgroup. Each member can be either the name of another netgroup or a specification of a tuple as follows:
(host, user, domain)
where the host, user, and domain are character string names for the corresponding component. Any of the comma separated fields may be empty to specify a “wildcard” value or may consist of the string “
-” to specify “no valid value”. The members of the list may be separated by whitespace; the “\” character may be used at the end of a line to specify line continuation. The functions specified in getnetgrent(3) should normally be used to access the netgroup database.
If ‘files’ is specified for the ‘netgroup’ database in nsswitch.conf(5), (or no ‘netgroup’ entry is specified), then these functions operate on the db(3) version of the netgroup (netgroup.db) file which can be generated using netgroup_mkdb(8). If ‘nis’ is specified then the NIS maps ‘netgroup’, ‘netgroup.byhost’, and ‘netgroup.byuser’ are used.
Lines that begin with a # are treated as comments.
- the netgroup database.
SEE ALSOgetnetgrent(3), exports(5), nsswitch.conf(5), netgroup_mkdb(8)
COMPATIBILITYThe file format is compatible with that of various vendors, however it appears that not all vendors use an identical format.
BUGSThe interpretation of access restrictions based on the member tuples of a netgroup is left up to the various network applications.
|January 16, 1999||NetBSD 7.0|