Manual browser: shells(5)
|SHELLS(5)||File Formats Manual||SHELLS(5)|
NAMEshells — shell database
DESCRIPTIONThe shells file contains a list of the shells on the system. It can be used in conjunction with the Hesiod domain ‘shells’, and the NIS map ‘shells’, as controlled by nsswitch.conf(5).
For each shell a single line should be present, consisting of the shell's path, relative to root.
A hash (“#”) indicates the beginning of a comment; subsequent characters up to the end of the line are not interpreted by the routines which search the file. Blank lines are also ignored.
- The shells file resides in /etc.
SEE ALSOchsh(1), getusershell(3), nsswitch.conf(5)
HISTORYThe shells file format appeared in 4.3BSD-Tahoe.
The Hesiod and NIS support first appeared in NetBSD 1.4.
|January 16, 1999||NetBSD 7.0|