Manual browser: lint(7)

Section:
Page:
LINT(7) Miscellaneous Information Manual LINT(7)

NAME

lintLint error message list

DESCRIPTION

The following is a list of message id's and messages produced by lint(1). It is intended to be used with -X flag of lint(1).

0 empty declaration
 old style declaration; add int
 empty declaration
 %s declared in argument declaration list
 illegal type combination
 modifying typedef with '%s'; only qualifiers allowed
 use 'double' instead of 'long float'
 only one storage class allowed
 illegal storage class
 only register valid as formal parameter storage class
 duplicate '%s'
 bit-field initializer out of range
 compiler takes size of function
 incomplete enum type: %s
 compiler takes alignment of function
 function returns illegal type
 array of function is illegal
 null dimension
 illegal use of 'void'
 void type for %s
 negative array dimension (%d)
 redeclaration of formal parameter %s
 incomplete or misplaced function definition
 undefined label %s
 cannot initialize function: %s
 cannot initialize typedef: %s
 cannot initialize extern declaration: %s
 redeclaration of %s
 redefinition of %s
 previously declared extern, becomes static: %s
 redeclaration of %s; ANSI C requires static
 incomplete structure or union %s: %s
 argument type defaults to 'int': %s
 duplicate member name: %s
 nonportable bit-field type
 illegal bit-field type
 illegal bit-field size
 zero size bit-field
 function illegal in structure or union
 zero sized array in struct is a C99 extension: %s
 unknown size: %s
 illegal use of bit-field
 forward reference to enum type
 redefinition hides earlier one: %s
 declaration introduces new type in ANSI C: %s %s
 base type is really '%s %s'
 (%s) tag redeclared
 zero sized %s is a C9X feature
 overflow in enumeration values: %s
 struct or union member must be named
 a function is declared as an argument: %s
 parameter mismatch: %d declared, %d defined
 cannot initialize parameter: %s
 declared argument %s is missing
 trailing ',' prohibited in enum declaration
 integral constant expression expected
 integral constant too large
 enumeration constant hides parameter: %s
 type does not match prototype: %s
 formal parameter lacks name: param #%d
 void must be sole parameter
 void parameter cannot have name: %s
 function prototype parameters must have types
 prototype does not match old-style definition
 ()-less function definition
 %s has no named members
 syntax requires ';' after last struct/union member
 cannot return incomplete type
 typedef already qualified with '%s'
 inappropriate qualifiers with 'void'
 %soperand of '%s' is unsigned in ANSI C
 too many characters in character constant
 typedef declares no type name
 empty character constant
 no hex digits follow \x
 overflow in hex escape
 character escape does not fit in character
 bad octal digit %c
 nonportable character escape
 dubious escape \%c
 dubious escape \%o
 \a undefined in traditional C
 \x undefined in traditional C
 storage class after type is obsolescent
 ANSI C requires formal parameter before '...'
 dubious tag declaration: %s %s
 automatic hides external declaration: %s
 static hides external declaration: %s
 typedef hides external declaration: %s
 typedef redeclared: %s
 inconsistent redeclaration of extern: %s
 declaration hides parameter: %s
 inconsistent redeclaration of static: %s
 dubious static function at block level: %s
 function has illegal storage class: %s
 declaration hides earlier one: %s
 cannot dereference non-pointer type
 suffix U is illegal in traditional C
 suffixes F and L are illegal in traditional C
 %s undefined
 unary + is illegal in traditional C
 undefined struct/union member: %s
 illegal member use: %s
 left operand of '.' must be struct/union object
 left operand of '->' must be pointer to struct/union
 non-unique member requires struct/union %s
 left operand of '->' must be pointer
 operands of '%s' have incompatible types (%s != %s)
 operand of '%s' has incompatible type (%s != %s)
 void type illegal in expression
 pointer to function is not allowed here
 unacceptable operand of '%s'
 cannot take address of bit-field
 cannot take address of register %s
 %soperand of '%s' must be lvalue
 %soperand of '%s' must be modifiable lvalue
 illegal pointer subtraction
 bitwise operation on signed value possibly nonportable
 semantics of '%s' change in ANSI C; use explicit cast
 conversion of '%s' to '%s' is out of range
 bitwise operation on signed value nonportable
 negative shift
 shift greater than size of object
 illegal combination of pointer and integer, op %s
 illegal pointer combination, op %s
 ANSI C forbids ordered comparisons of pointers to functions
 incompatible types in conditional
 '&' before array or function: ignored
 operands have incompatible pointer types, op %s (%s != %s)
 expression has null effect
 enum type mismatch, op %s
 conversion to '%s' may sign-extend incorrectly
 conversion from '%s' to '%s' may lose accuracy
 conversion of pointer to '%s' loses bits
 conversion of pointer to '%s' may lose bits
 possible pointer alignment problem
 cannot do pointer arithmetic on operand of unknown size
 use of incomplete enum type, op %s
 unknown operand size, op %s
 division by 0
 modulus by 0
 integer overflow detected, op %s
 floating point overflow detected, op %s
 cannot take size/alignment of incomplete type
 cannot take size/alignment of function
 cannot take size/alignment of bit-field
 cannot take size/alignment of void
 invalid cast expression
 improper cast of void expression
 illegal function (type %s)
 argument mismatch: %d arg%s passed, %d expected
 void expressions may not be arguments, arg #%d
 argument cannot have unknown size, arg #%d
 argument has incompatible pointer type, arg #%d (%s != %s)
 illegal combination of pointer and integer, arg #%d
 argument is incompatible with prototype, arg #%d
 enum type mismatch, arg #%d
 ANSI C treats constant as unsigned
 %s may be used before set
 assignment in conditional context
 operator '==' found where '=' was expected
 constant in conditional context
 comparison of %s with %s, op %s
 a cast does not yield an lvalue
 assignment of negative constant to unsigned type
 constant truncated by assignment
 precision lost in bit-field assignment
 array subscript cannot be negative: %ld
 array subscript cannot be > %d: %ld
 precedence confusion possible: parenthesize!
 first operand must have scalar type, op?:
 assignment type mismatch (%s != %s)
 too many struct/union initializers
 too many array initializers, expected %d
 too many initializers
 initialisation of an incomplete type
 invalid initializer type %s
 non-constant initializer
 initializer does not fit
 cannot initialize struct/union with no named member
 bit-field initializer does not fit
 {}-enclosed initializer required
 incompatible pointer types (%s != %s)
 illegal combination of pointer and integer
 illegal pointer combination
 initialisation type mismatch
 bit-field initialisation is illegal in traditional C
 non-null byte ignored in string initializer
 no automatic aggregate initialization in traditional C
 assignment of struct/union illegal in traditional C
 empty array declaration: %s
 %s set but not used in function %s
 %s unused in function %s
 statement not reached
 label %s redefined
 case not in switch
 case label affected by conversion
 non-constant case expression
 non-integral case expression
 duplicate case in switch: %ld
 duplicate case in switch: %lu
 default outside switch
 duplicate default in switch
 case label must be of type `int' in traditional C
 controlling expressions must have scalar type
 switch expression must have integral type
 enumeration value(s) not handled in switch
 loop not entered at top
 break outside loop or switch
 continue outside loop
 enum type mismatch in initialisation
 return value type mismatch
 cannot return incomplete type
 void function %s cannot return value
 function %s expects to return value
 function implicitly declared to return int
 function %s has return (e); and return;
 function %s falls off bottom without returning value
 ANSI C treats constant as unsigned, op %s
 concatenated strings are illegal in traditional C
 fallthrough on case statement
 initialisation of unsigned with negative constant
 conversion of negative constant to unsigned type
 end-of-loop code not reached
 cannot recover from previous errors
 static function called but not defined: %s()
 static variable %s unused
 const object %s should have initializer
 function cannot return const or volatile object
 questionable conversion of function pointer
 nonportable character comparison, op %s
 argument %s unused in function %s
 label %s unused in function %s
 struct %s never defined
 union %s never defined
 enum %s never defined
 static function %s unused
 redeclaration of formal parameter %s
 initialisation of union is illegal in traditional C
 constant argument to NOT
 assignment of different structures (%s != %s)
 dubious operation on enum, op %s
 combination of '%s' and '%s', op %s
 dubious comparison of enums, op %s
 illegal structure pointer combination
 illegal structure pointer combination, op %s
 dubious conversion of enum to '%s'
 pointer casts may be troublesome
 floating-point constant out of range
 syntax error '%s'
 unknown character \%o
 malformed integer constant
 integer constant out of range
 unterminated character constant
 newline in string or char constant
 undefined or invalid # directive
 unterminated comment
 extra characters in lint comment
 unterminated string constant
 conversion to '%s' due to prototype, arg #%d
 previous declaration of %s
 previous definition of %s
 \" inside character constants undefined in traditional C
 \? undefined in traditional C
 \v undefined in traditional C
 %s C does not support 'long long'
 'long double' is illegal in traditional C
 shift equal to size of object
 variable declared inline: %s
 argument declared inline: %s
 function prototypes are illegal in traditional C
 switch expression must be of type `int' in traditional C
 empty translation unit
 bit-field type '%s' invalid in ANSI C
 ANSI C forbids comparison of %s with %s
 cast discards 'const' from pointer target type
 __%s__ is illegal for type %s
 initialisation of '%s' with '%s'
 combination of '%s' and '%s', arg #%d
 combination of '%s' and '%s' in return
 must be outside function: /* %s */
 duplicate use of /* %s */
 must precede function definition: /* %s */
 argument number mismatch with directive: /* %s */
 fallthrough on default statement
 prototype declaration
 function definition is not a prototype
 function declaration is not a prototype
 dubious use of /* VARARGS */ with /* %s */
 can't be used together: /* PRINTFLIKE */ /* SCANFLIKE */
 static function %s declared but not defined
 invalid multibyte character
 cannot concatenate wide and regular string literals
 argument %d must be 'char *' for PRINTFLIKE/SCANFLIKE
 multi-character character constant
 conversion of '%s' to '%s' is out of range, arg #%d
 conversion of negative constant to unsigned type, arg #%d
 conversion to '%s' may sign-extend incorrectly, arg #%d
 conversion from '%s' to '%s' may lose accuracy, arg #%d
 prototype does not match old style definition, arg #%d
 old style definition
 array of incomplete type
 %s returns pointer to automatic object
 ANSI C forbids conversion of %s to %s
 ANSI C forbids conversion of %s to %s, arg #%d
 ANSI C forbids conversion of %s to %s, op %s
 constant truncated by conversion, op %s
 static variable %s set but not used
 Invalid type %s for _Complex
 extra bits set to 0 in conversion of '%s' to '%s', op %s
 symbol renaming can't be used on function arguments
 symbol renaming can't be used on automatic variables
 %s C does not support // comments
 struct or union member name in initializer is a C9X feature
 %s is not a structure or a union
 GCC style struct or union member name in initializer
 __FUNCTION__/__PRETTY_FUNCTION__ is a GCC extension
 __func__ is a C9X feature
 variable array dimension is a C99/GCC extension
 compound literals are a C9X/GCC extension
 ({ }) is a GCC extension
 array initializer with designators is a C9X feature
 zero sized array is a C99 extension
 continue in 'do ... while (0)' loop
 suggest cast from '%s' to '%s' on op %s to avoid overflow
 variable declaration in for loop
 %s attribute ignored for %s
 declarations after statements is a C9X feature
July 5, 2000 NetBSD 7.0