Manual browser: mailaddr(7)
|MAILADDR(7)||Miscellaneous Information Manual||MAILADDR(7)|
NAMEmailaddr — mail addressing description
DESCRIPTIONMail addresses are based on the Internet protocol listed at the end of this manual page. These addresses are in the general format
where a domain is a hierarchical dot separated list of subdomains. For example, a valid address is:
Unlike some other (now obsolete) forms of addressing, domains do not imply any routing, or the existence of a particular host. Simply because mail may be sent to ``firstname.lastname@example.org'' does not imply that there is any actual host named ``somedomain.com'', and does not imply a particular routing of the message. Routing is performed by Mail Transport Agents, such as postfix(1), based on policies set in the MTA's configuration.
AbbreviationUnder certain circumstances it may not be necessary to type the entire domain name. In general, anything following the first dot may be omitted if it is the same as the domain from which you are sending the message. For example, a user on ``calder.berkeley.edu'' could send to ``eric@CS'' without adding the ``berkeley.edu'' since it is the same on both sending and receiving hosts. Whether abbreviation is permitted depends on how your site is configured.
Case DistinctionsDomain names (i.e., anything after the ``@'' sign) may be given in any mixture of upper and lower case. Most hosts accept any combination of case in user names, although there are exceptions.
PostmasterEvery site is required to have a user or user alias designated ``postmaster'' to which problems with the mail system may be addressed, for example:
Obsolete FormatsCertain old address formats, such as UUCP ``bang path'' addresses, explicitly routed internet addresses (so-called ``route-addrs'' and the ``percent hack'') and others have been used historically. All these addressing formats are now considered obsolete, and should no longer be used.
To some extent, MTAs attempt to provide backward compatibility for these addressing forms, but in practice many of them no longer work. Users should always use standard Internet style addresses.
D. H. Crocker, Standard for the Format of Arpa Internet Text Messages, RFC, 822, August 1982.
HISTORYmailaddr appeared in 4.2BSD.
BUGSThe RFC 822 group syntax (``group:user1,user2,user3;'') is not supported except in the special case of ``group:;'' because of a conflict with old berknet-style addresses, not that anyone cares about either berknet or group syntax style addresses any longer.
|June 16, 1998||NetBSD 7.0|