Manual browser: operator(7)

Section:
Page:
OPERATOR(7) Miscellaneous Information Manual OPERATOR(7)

NAME

operatorC and C++ operator precedence and associativity

DESCRIPTION

Operator Associativity
() [] -> . left to right
! ~ ++ -- - (type) * & sizeof new delete right to left
->* .* left to right
* / % left to right
+ - left to right
<< >> left to right
< <= > >= left to right
== != left to right
& left to right
^ left to right
| left to right
&& left to right
|| left to right
?: right to left
= += -= *= /= %= <<= >>= &= ^= |= throw right to left
?: (C++, third operand) right to left
, left to right

FILES

/usr/share/misc/operator

SEE ALSO

iso646(3)
January 18, 2011 NetBSD 7.0