Manual browser: btattach(8)
|BTATTACH(8)||System Manager's Manual||BTATTACH(8)|
NAMEbtattach — attach serial lines as Bluetooth HCI interfaces
|btattach||[-dFfoPp] [-i speed] [type] tty speed|
|btattach||-t [-dFfoPp] tty|
DESCRIPTIONbtattach is used to assign a tty line to a Bluetooth Host Controller Interface using the btuart(4) or bcsp(4) line disciplines, and can optionally initialize the line for a given device type before activating the line discipline.
Supported types are:
- Broadcom BCM2035
- Generic BCSP (BlueCore Serial Protocol)
- Philips BGB2xx module
- Generic UART (this is the default)
- Cambridge Silicon Radio Casira serial adapter, or Brainboxes serial dongle (BL642)
- Ericsson based modules
- Digianswer based cards
- ST Microelectronics minikits based on STLC2410/STLC2415
- ST Microelectronics minikits based on STLC2500
- Silicon Wave kits
- Texas Instruments modules
- Infineon UniStone (PBA31308) modules
When the line discipline is activated, btattach detaches and sleeps until it receives a SIGHUP.
The command line options are as follows:
- debug mode. print initialization IO and do not detach.
- Disable flow control.
- Enable flow control.
- -i speed
- Specify an alternate speed for the Bluetooth module to use during the initialization phase.
- Enable odd parity.
- Disable parity.
- Enable parity (even parity).
- Test mode.
Only the super-user may attach a Bluetooth HCI interface.
Test mode tries to guess the speed using the received link-establish packet from HCI, or btuart(4), if there is no response.
SEE ALSObcsp(4), bluetooth(4), btuart(4), btconfig(8)
HISTORYThe btattach program was written with reference to hciattach(8) as provided with the BlueZ tools for Linux and first appeared in NetBSD 5.0.
BUGSNot all type initializations have been tested.
|March 9, 2010||NetBSD 7.0|