Manual browser: dhcpcd-run-hooks(8)
|DHCPCD-RUN-HOOKS(8)||System Manager's Manual||DHCPCD-RUN-HOOKS(8)|
NAMEdhcpcd-run-hooks — DHCP client configuration script
DESCRIPTIONdhcpcd-run-hooks is used by dhcpcd(8) to run any system and user defined hook scripts. System hook scripts are found in /libexec/dhcpcd-hooks and the user defined hooks are /etc/dhcpcd.enter-hook. and /etc/dhcpcd.exit-hook. The default install supplies hook scripts for configuring /etc/resolv.conf and the hostname. Your distribution may have included other hook scripts to say configure ntp or ypbind. A test hook is also supplied that simply echos the dhcp variables to the console from DISCOVER message.
Each time dhcpcd-run-hooks is invoked, $interface is set to the interface that dhcpcd is run on and $reason is to the reason why dhcpcd-run-hooks was invoked. DHCP information to be configured is held in variables starting with the word new_ and old DHCP information to be removed is held in variables starting with the word old_. dhcpcd can display the full list of variables it knows how about by using the -V, --variables argument.
Here's a list of reasons why dhcpcd-run-hooks could be invoked:
- dhcpcd is starting up and any pre-initialisation should be done.
- dhcpcd has detected the carrier is up. This is generally just a notification and no action need be taken.
- dhcpcd lost the carrier. The cable may have been unplugged or association to the wireless point lost.
- INFORM | INFORM6
- dhcpcd informed a DHCP server about it's address and obtained other configuration details.
- BOUND | BOUND6
- dhcpcd obtained a new lease from a DHCP server.
- RENEW | RENEW6
- dhcpcd renewed it's lease.
- REBIND | REBIND6
- dhcpcd has rebound to a new DHCP server.
- REBOOT | REBOOT6
- dhcpcd successfully requested a lease from a DHCP server.
- dhcpcd assigned a delegated prefix to the interface.
- dhcpcd failed to contact any DHCP servers but did obtain an IPV4LL address.
- dhcpcd has been configured with a static configuration which has not been obtained from a DHCP server.
- dhcpcd is monitoring the interface for a 3rd party to give it an IP address.
- dhcpcd failed to contact any DHCP servers but was able to use an old lease.
- EXPIRE | EXPIRE6
- dhcpcd's lease or state expired and it failed to obtain a new one.
- dhcpcd received a NAK from the DHCP server. This should be treated as EXPIRE.
- dhcpcd has been instructed to reconfigure an interface.
- dhcpcd has received an IPv6 Router Advertisment, or one has expired.
- STOP | STOP6
- dhcpcd stopped running on the interface.
- dhcpcd has stopped entirely.
- The interface has been removed.
- dhcpcd failed to operate on the interface. This normally happens when dhcpcd does not support the raw interface, which means it cannot work as a DHCP or ZeroConf client. Static configuration and DHCP INFORM is still allowed.
- dhcpcd has been asked to dump the last lease for the interface.
- dhcpcd received an OFFER from a DHCP server but will not configure the interface. This is primarily used to test the variables are filled correctly for the script to process them.
ENVIRONMENTdhcpcd will clear the environment variables aside from $PATH and $RC_SVCNAME. The following variables will then be set, along with any protocol supplied ones.
- the name of the interface.
- as described above.
- the pid of dhcpcd.
- the link status of $interface: unknown, up or down.
- $interface preference, lower is better.
- 1 if $interface is wireless, otherwise 0.
- $interface flags.
- $interface MTU.
- the name of the SSID the interface is connected to.
- A list of interfaces, in order of preference.
- true if the interface is up, otherwise false.
- true if the interface is down, otherwise false.
- true if any interface is up, otherwise false.
- true if any interface has been assigned an IP address which matches any wait requirements specified in dhcpcd.conf(5).
- the name of the profile selected from dhcpcd.conf(5).
- space separated list of delegated prefixes.
FILESWhen dhcpcd-run-hooks runs, it loads /etc/dhcpcd.enter-hook and any scripts found in /libexec/dhcpcd-hooks in a lexical order and then finally /etc/dhcpcd.exit-hook
BUGSPlease report them to http://roy.marples.name/projects/dhcpcd
SECURITY CONSIDERATIONSdhcpcd will validate the content of each option against its encoding. For string, ascii, raw or binhex encoding it's up to the user to validate it for the intended purpose.
When used in a shell script, each variable must be quoted correctly.
|October 3, 2014||NetBSD 7.0|