Manual browser: iostat(8)
|IOSTAT(8)||System Manager's Manual||IOSTAT(8)|
NAMEiostat — report I/O statistics
|iostat||[-CdDITx] [-c count] [-w wait] [drives]|
DESCRIPTIONiostat displays kernel I/O statistics on terminal, disk and CPU operations. By default, iostat displays one line of statistics averaged over the machine's run time. The use of -c presents successive lines averaged over the wait period. The -I option causes iostat to print raw, unaveraged values.
Only the last disk option specified (-d, -D, or -x) is used.
The options are as follows:
- -c count
- Repeat the display count times. Unless the -I flag is in effect, the first display is for the time since a reboot and each subsequent report is for the time period since the last display. If no wait interval is specified, the default is 1 second.
- Show CPU statistics. This is enabled by default unless the -d, -D, -T, or -x flags are used.
- Show disk statistics. This is the default. Displays kilobytes per transfer, number of transfers, and megabytes transferred. Use of this flag disables display of CPU and tty statistics.
- Show alternative disk statistics. Displays kilobytes transferred, number of transfers, and time spent in transfers. Use of this flag disables the default display.
- Show the running total values, rather than an average.
- Show tty statistics. This is enabled by default unless the -C, -d, or -D flags are used.
- -w wait
- Pause wait seconds between each display. If no repeat count is specified, the default is infinity.
- Show extended disk statistics. Each disk is displayed on a line of its own with all available statistics. This option overrides all other display options, and all disks are displayed unless specific disks are provided as arguments. Additionally, separate read and write statistics are displayed.
iostat displays its information in the following format:
- characters read from terminals
- characters written to terminals
Disk operations. The header of the field is the disk name and unit number. If more than four disk drives are configured in the system, iostat displays only the first four drives. To force iostat to display specific drives, their names may be supplied on the command line.
- Kilobytes transferred per disk transfer
- transfers per second
- Megabytes transferred per second
The alternative display format, (selected with -D), presents the following values.
- Kilobytes transferred
- Disk transfers
- Seconds spent in disk activity
- % of CPU time in user mode
- % of CPU time in user mode running niced processes
- % of CPU time in system mode
- % of CPU time in idle mode
SEE ALSOfstat(1), netstat(1), nfsstat(1), ps(1), systat(1), vmstat(1), pstat(8)
The sections starting with ``Interpreting system activity'' in Installing and Operating 4.3BSD.
HISTORYiostat appeared in Version 6 AT&T UNIX. The -x option was added in NetBSD 1.4.
|June 11, 2014||NetBSD 7.0|