Manual browser: nfsd(8)
|NFSD(8)||System Manager's Manual||NFSD(8)|
NAMEnfsd — remote NFS server
|nfsd||[-46rut] [-n num_threads]|
DESCRIPTIONnfsd runs on a server machine to service NFS requests from client machines. At least one nfsd must be running for a machine to operate as a server.
Unless otherwise specified, four servers for UDP transport are started.
The following options are available:
- Register the NFS service with rpcbind(8) without creating any servers. This option can be used along with the -u or -t options to re-register NFS if the portmap server is restarted.
- Specifies how many server threads to create. The default is 4. A server should run enough threads to handle the maximum level of concurrency from its clients.
- Only listen to IPv4 requests. By default nfsd listens to both IPv6 and IPv4 and tries to register for both.
- Only listen to IPv6 requests.
- Serve only TCP NFS clients. By default nfsd serves both TCP NFS and UDP NFS clients
- Serve only UDP NFS clients.
nfsd listens for service requests at the port indicated in the NFS server specification; see Network File System Protocol Specification, RFC 1094 and NFS: Network File System Version 3 Protocol Specification.
EXIT STATUSThe nfsd utility exits 0 on success, and >0 if an error occurs.
nfsd -n 6” serves UDP and TCP transports using six threads.
SEE ALSOnfsstat(1), nfssvc(2), mountd(8), rpcbind(8)
HISTORYThe nfsd utility first appeared in 4.4BSD.
|August 12, 2012||NetBSD 7.0|