Manual browser: pam_deny(8)
|PAM_DENY(8)||System Manager's Manual||PAM_DENY(8)|
NAMEpam_deny — Deny PAM module
SYNOPSIS[service-name] module-type control-flag pam_deny [options]
DESCRIPTIONThe deny authentication service module for PAM provides functionality for all the PAM categories: authentication, account management, session management and password management. In terms of the module-type parameter, these are the “
session”, and “
The Deny module will universally deny all requests. It is primarily of use during testing, and to “null-out” unwanted functionality.
The following options may be passed to the module:
- syslog(3) debugging information at LOG_DEBUG level.
- suppress warning messages to the user. These messages include reasons why the user's authentication attempt was declined.
for password management (“
password” feature), return PAM_IGNORE in the preliminary phase. This allows the module to be used (with the “
required” flag) at the end of a chain of “
sufficient” modules with this service (where the entire chain is in fact run twice).
|August 21, 2013||NetBSD 7.0|