Manual browser: ssh-keysign(8)
|SSH-KEYSIGN(8)||System Manager's Manual||SSH-KEYSIGN(8)|
NAMEssh-keysign — ssh helper program for host-based authentication
DESCRIPTIONssh-keysign is used by ssh(1) to access the local host keys and generate the digital signature required during host-based authentication with SSH protocol version 2.
ssh-keysign is disabled by default and can only be enabled in the global client configuration file /etc/ssh/ssh_config by setting EnableSSHKeysign to “yes”.
ssh-keysign is not intended to be invoked by the user, but from ssh(1). See ssh(1) and sshd(8) for more information about host-based authentication.
Controls whether ssh-keysign is enabled.
These files contain the private parts of the host keys used to generate the digital signature. They should be owned by root, readable only by root, and not accessible to others. Since they are readable only by root, ssh-keysign must be set-uid root if host-based authentication is used.
- If these files exist they are assumed to contain public certificate information corresponding with the private keys above.
SEE ALSOssh(1), ssh-keygen(1), ssh_config(5), sshd(8)
HISTORYssh-keysign first appeared in OpenBSD 3.2.
|December 7 2013||NetBSD 7.0|