Manual browser: timedc(8)
|TIMEDC(8)||System Manager's Manual||TIMEDC(8)|
NAMEtimedc — timed control program
|timedc||[command [argument ...]]|
DESCRIPTIONtimedc is used to control the operation of the timed(8) program. It may be used to:
- Measure the differences between machines' clocks,
- Find the location where the master time server is running,
- Enable or disable tracing of messages received by timed(8), and
- Perform various debugging actions.
Without any arguments, timedc will prompt for commands from the standard input. If arguments are supplied, timedc interprets the first argument as a command and the remaining arguments as parameters to the command. The standard input may be redirected causing timedc to read commands from a file. Commands may be abbreviated; recognized commands are:
- ? [command ...]
- help [command ...]
Print a short description of each command specified in the argument list, or, if no arguments are given, a list of the recognized commands.
- clockdiff host ...
Compute the differences between the clock of the host machine and the clocks of the machines given as arguments.
- msite [host ...]
Show the master time server for specified host(s).
Enable or disable the tracing of incoming messages to timed(8) in the file /var/log/timed.log.
- election host
Asks the daemon on the target host to reset its “election” timers and to ensure that a time master has been elected.
- Exit from timedc.
Other commands may be included for use in testing and debugging timed(8); the help command and the program source may be consulted for details.
- tracing file for timed
- log file for master timed
- ?Ambiguous command
- abbreviation matches more than one command
- ?Invalid command
- no match found
SEE ALSOdate(1), adjtime(2), icmp(4), timed(8)
R. Gusella and S. Zatti, TSP: The Time Synchronization Protocol for UNIX 4.3BSD.
HISTORYThe timedc command appeared in 4.3BSD.
|February 2, 2007||NetBSD 7.0|