Manual browser: wlanctl(8)
|WLANCTL(8)||System Manager's Manual||WLANCTL(8)|
NAMEwlanctl — examine IEEE 802.11 wireless LAN client/peer table
|wlanctl||[-p] interface [...]|
DESCRIPTIONUse the wlanctl utility to print node tables from IEEE 802.11 interfaces. Use the -a flag to print the nodes for all interfaces, or list one or more 802.11 interfaces to select their tables for examination. The -p flag causes only nodes that do not have encryption enabled to be printed. For example, to examine the node tables for atw0, use:
wlanctl may print this node table, for example:
atw0: mac 00:02:6f:20:f6:2e bss 02:02:6f:20:f6:2e node flags 0001<bss> ess <netbsd> chan 11 freq 2462MHz flags 00a0<cck,2.4GHz> capabilities 0022<ibss,short preamble> beacon-interval 100 TU tsft 18425852102545544165 us rates [1.0] 2.0 5.5 11.0 assoc-id 0 assoc-failed 0 inactivity 0s rssi 161 txseq 10 rxseq 1420 atw0: mac 00:02:2d:2e:3c:f4 bss 02:02:6f:20:f6:2e node flags 0000 ess <netbsd> chan 11 freq 2462MHz flags 00a0<cck,2.4GHz> capabilities 0002<ibss> beacon-interval 100 TU tsft 18425852105450086784 us rates [1.0] 2.0 5.5 11.0 assoc-id 0 assoc-failed 0 inactivity 0s rssi 159 txseq 2 rxseq 551 atw0: mac 00:02:6f:20:f6:2e bss 02:02:6f:20:f6:2e node flags 0000 ess <netbsd> chan 11 freq 2462MHz flags 00a0<cck,2.4GHz> capabilities 0022<ibss,short preamble> beacon-interval 100 TU tsft 18425852102558548069 us rates [1.0] 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0 assoc-id 0 assoc-failed 0 inactivity 145s rssi 163 txseq 9 rxseq 2563
This example is taken from a network consisting of three stations running in ad hoc mode. The key for interpreting the node print-outs follows:
- In the example node table, the first network node has MAC number 00:02:6f:20:f6:2e.
- The first node belongs to the 802.11 network identified by Basic Service Set Identifier (BSSID) 02:02:6f:20:f6:2e.
- node flags
- Only three node flags, “bss”, “sta”, and “scan”, are presently defined. The first node is distinguished from the rest by its node flags: flag “bss” indicates that the node represents the 802.11 network that the interface has joined or created. The MAC number for the node is the same as the MAC number for the interface.
- the name of the (Extended) Service Set we have joined. This is the same as the network name set by ifconfig(8) with the “ssid” option.
wlanctl prints the channel number, the center frequency in megahertz, and the channel flags. The channel flags indicate the frequency band (“2.4GHz” or “5GHz”), modulation (“cck”, “gfsk”, “ofdm”, “turbo”, and “dynamic cck-ofdm”), and operation constraints (“passive scan”). Common combinations of band and modulation are these:
Band Modulation Description 2.4GHz cck 11Mb/s DSSS 802.11b 2.4GHz gfsk 1-2Mb/s FHSS 802.11 2.4GHz ofdm 54Mb/s 802.11g 2.4GHz dynamic cck-ofdm mixed 802.11b/g network 5GHz ofdm 54Mb/s 802.11a 5GHz turbo 108Mb/s 802.11a
ad hoc-mode and AP-mode 802.11 stations advertise their capabilities in 802.11 Beacons and Probe Responses. wlanctl understands these capability flags:
Flag Description ess infrastructure (access point) network ibss ad hoc network (no access point) cf pollable TBD request cf poll TBD privacy WEP encryption short preamble reduce 802.11b overhead pbcc 22Mbps ``802.11b+'' channel agility change channel for licensed services short slot-time TBD rsn TBD Real Soon Now dsss-ofdm TBD
- In the example, beacons are sent once every 100 Time Units. A Time Unit (TU) is 1024 microseconds (a “kilo-microsecond” or “kus”). Thus 100 TU is about one tenth of a second.
- 802.11 stations keep a Time Synchronization Function Timer (TSFT) which counts up in microseconds. Ad hoc-mode stations synchronize time with their peers. Infrastructure-mode stations synchronize time with their access point. Power-saving stations wake and sleep at intervals measured by the TSF Timer. The TSF Timer has a role in the coalescence of 802.11 ad hoc networks (“IBSS merges”).
- 802.11 stations indicate the bit-rates they support, in units of 100kb/s in 802.11 Beacons, Probe Responses, and Association Requests. wlanctl prints a station's supported bit-rates in 1Mb/s units. A station's basic rates are flagged by an asterisk (‘*’). The last bit-rate at which a packet was sent to the station is enclosed by square brackets.
- In an infrastructure network, the access point assigns each client an Association Identifier which is used to indicate traffic for power-saving stations.
- The number of times the station tried and failed to associate with its access point. Only
- Seconds elapsed since a packet was last received from the station. When this value reaches net.link.ieee80211.maxinact, the station is eligible to be purged from the node table. See sysctl(8).
- Unitless Received Signal Strength Indication (RSSI). Higher numbers indicate stronger signals. Zero is the lowest possible RSSI. On a hostap- or adhoc-mode interface, the node with node flag “bss” set uses rssi to indicate the signal strength for the last packet received from a station that does not belong to the network. On an infrastructure-mode station, the node with node flag “bss” set indicates the strength of packets from the access point.
- The next 802.11 packet sent to this station will carry this transmit sequence number. The 802.11 MAC uses the transmit sequence number to detect duplicate packets.
- The last packet received from this station carried this transmit sequence number.
HISTORYwlanctl first appeared in NetBSD 3.0.
|July 15, 2004||NetBSD 7.0|