Manual browser: SET(9)
|SET(9)||Kernel Developer's Manual||SET(9)|
NAMESET — primitive bit macros
DESCRIPTIONThese macros define three standard bit-operations:
- SET() sets the bit x in val;
- CLR() clears the bit x in val; and
- ISSET() returns 1 if the bit x is set in val.
BUGSThe rationale is to provide clarity in the source code, but arguably these operations are clear enough without the use of the macros.
|March 12, 2014||NetBSD 7.0|