Manual browser: delay(9)
|DELAY(9)||Kernel Developer's Manual||DELAY(9)|
NAMEdelay, DELAY — microsecond delay
delay(unsigned int us);
DELAY(unsigned int us);
DESCRIPTIONWait approximately us microseconds.
The delay is implemented as a machine loop, preventing events other than interrupt handlers for unmasked interrupts to run. DELAY() is reentrant (doesn't modify any global kernel or machine state) and is safe to use in interrupt or process context.
For long delays, condition variables should be considered, however they can only be used from process context and their resolution is limited by the system clock frequency.
|July 20, 2011||NetBSD 7.0|