Manual browser: ieee80211_ioctl(9)
|IEEE80211_IOCTL(9)||Kernel Developer's Manual||IEEE80211_IOCTL(9)|
NAMEieee80211_cfgget, ieee80211_cfgset, ieee80211_ioctl — 802.11 interface ioctl commands
ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data);
ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data);
ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data);
DESCRIPTIONThese functions are typically invoked by drivers in response to requests for information or to change settings from the userland.
The ieee80211_cfgget() and ieee80211_cfgset() functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility.
The ieee80211_ioctl() function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to ether_ioctl() when no match for cmd is found.
HISTORYThe ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6.
|September 12, 2006||NetBSD 7.0|